Seiten

Categories

Archive

Tags

development gem linux merge rails redcloth ruby server subversion svn typo windows

Syndikat

Versionen der verwendeten GEMs herausfinden (in Rails)

Ich habe leider schon wieder ein paar Probleme mit RedCloth. Ich habe, wie in einem früheren Artikel hier beschrieben, das GEM von RedCloth ausgepackt und eingebunden, damit ich sicherstellen kann, daß ich überall die gleiche Version (3.0.3) bekomme. Denn die neuere Version 3.0.4 hat ein ganz seltsames Verhalten, daß man fast als Bug bezeichnen kann.

Wie auch immer, leider hat mich beim Start meines Projekts, eine Fehlermeldung in Phusion Passenger erwartet, wo ich mein Projekt erwartet hatte.

Im Prozess des Debuggens (obwohl ich meines Wissens nichts verändert habe) kam öfter die Frage auf, welche Version von RedCloth denn jetzt eigentlich verwendet wird momentan.

Herausfinden kann man das in der Konsole mit folgendem Befehl:

RedCloth::VERSION

Vielleicht braucht das ja mal jemand. Im Prinzip sollte das für alle GEMs funktionieren, die ihre Versions-Nummer in der Hauptklasse im Feld VERSION speichern. Ich hoffe, daß das alle sind, die ich mal auf solche Art untersuchen will.

PS: Die Version von Rails, die gerade verwendet wird bekommt man mit:

Rails::VERSION::STRING

 

This entry was posted on Sat, 16 Aug 2008 17:14:00 GMT and Posted in . You can follow any any response to this entry through the Atom feed. You can leave a Kommentar or a trackback from your own site.
Tags , , , , ,


Trackbacks

Verwenden Sie den folgenden Link zur Rückverlinkung von Ihrer eigenen Seite:
http://blog.keyj.de/trackbacks?article_id=versionen-der-verwendeten-gems-herausfinden-in-rails&day=16&month=08&year=2008

Comments

Einen Kommentar hinterlassen

Leave a comment